TEST

Incident Report for Hailey HR

Update

We are continuing to investigate this issue.
Posted Apr 27, 2026 - 09:21 CEST

Investigating

Testar
Posted Apr 24, 2026 - 08:27 CEST
This incident affects: Core HR (Skills & Performance).